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Welcome to MCB GoldLink to 3CX! This User’s Guide explains how to set up and use GoldLink. Let’s start 

with a brief review of its features and system requirements. 

1. Features 
GoldLink to 3CX offers several key features to streamline your phone calls. 

Auto-Dial Outbound Calls 
Want to call a number in GoldMine? In GoldMine, just right-click and choose Dial Phone. Your desk 

phone rings immediately and you hear hold music while 3CX completes the call. 

Find GoldMine Records Using CallerID 
Receiving a call from someone already in GoldMine? Every time you receive a call, GoldLink searches 

GoldMine’s primary and additional contacts for a record matching the CallerID. You have the option of 

seeing the record in the current GoldMine window or in a new window. 

Add GoldMine History 
Whether making or receiving calls, it’s important to keep a record. GoldLink makes it easy, automatically 

adding a GoldMine history record to the proper contact. GoldLink optionally opens the Complete a Call 

dialog so you can add notes while you talk on the phone. 

Link to 3CX Recordings 
If you’re using the 3CX feature to record all your phone calls, you can set up GoldLink to add a link to the 

recording in the corresponding call history record. This allows you to quickly find and review call 

recordings associated with GoldMine history. (Of course, it’s up to you to make sure call recording is 

allowed.) 

 

 

 

 

 

 

 

 

MCB GoldLink to 3CX software, the 3CX Command Line API Plugin, and this User’s Guide, are copyright 2018 by 

MCB Systems. All rights reserved. All other product names, including GoldMine and 3CX, are the property of their 

respective owners. 
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2. System Requirements 
The MCB GoldLink to 3CX program is updated more often than this document. For current system 

requirements, see the GoldLink product page online at www.mcbsys.com/goldlink. 

GoldLink has been tested with 10-digit North American phone numbers. Under certain circumstances, 

GoldLink may work with variable-length numbers in other parts of the world—contact MCB Systems for 

details. 

While we can’t guarantee compatibility with your program versions and environment, we offer a 30-day 

free trial so you can try it for yourself! 

http://www.mcbsys.com/goldlink
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3. Before Installing GoldLink 
MCB GoldLink to 3CX must be locally installed on each computer where you run GoldMine. GoldLink 

relies on 3CX components. You must install 3CXPhone for Windows before installing GoldLink. If you 

haven’t already, install 3CXPhone as described below. 

3CX provides a custom softphone called 3CXPhone for Windows that integrates with the 3CX server to 

provide softphone capabilities as well as call logs, presence information, and other features. 

 

Follow the instructions here to install and provision 3CXPhone: 

http://www.3cx.com/user-manual/installation-windows/ 

When 3CXPhone is running, you’ll see this icon in your system tray: 

 

http://www.3cx.com/user-manual/installation-windows/
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4. Installing GoldLink 
Follow these steps to install MCB GoldLink to 3CX: 

1. Start GoldMine. 

2. Download and run the current setup program for MCB GoldLink to 3CX from 

www.mcbsys.com/goldlink. (If you are updating to a newer version, you do not need to uninstall 

your old version first.) 

3. Complete the installation as usual. Be sure to review the license agreement. 

4. When the installation completes, GoldLink starts automatically. See “Configuring GoldLink” 

below. 

Note Due to a limitation in GoldMine, GoldLink must be installed in a path that does not contain spaces. 

The default path is C:\GoldLinkTo3CX. 

If you get an “Access is denied” error during installation, your anti-virus may be blocking the install. See 

“Access Denied Error During Installation” on page 28. 

3CX Command Line API Plugin 
If the GoldLink installer detects that you 3CXPhone for Windows is installed, the installer will also install 

the 3CX Command Line API Plugin, which is a 3CXPhone for Windows add-on that allows GoldLink to 

integrate with 3CX. If 3CXPhone was not already installed when you installed GoldLink, the Command 

Line API Plugin will not be installed. Please install 3CXPhone before installing GoldLink. 

Uninstalling GoldLink 
To remove GoldLink, open Control Panel, then Programs > Uninstall a program. Highlight MCB GoldLink 

to 3CX and uninstall it. If the 3CX Command Line API Plugin is installed, it will also be removed. 

http://www.mcbsys.com/goldlink
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5. Configuring GoldLink 
GoldLink normally runs in the background each time you make or receive a call. However if you start 

GoldLink from the Windows Start menu, you will see a configuration screen where you can set up how 

GoldLink interacts with GoldMine and 3CX. 

Running GoldLink for the First Time 
The first time you run GoldLink, you will receive up to three prompts asking your permission to configure 

GoldMine to use GoldLink for outbound dialing. 

1. Start GoldMine. 

2. Start MCB GoldLink to 3CX. 

3. You must answer Yes to each question to be able to use GoldLink: 
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4. After allowing those changes, you will be asked to close and re-open GoldMine. Click OK to 

finish starting GoldLink.  

 
 

5. Close and re-start GoldMine. 

Setting GoldLink Options 
When you start GoldLink from the Windows Start menu, you will see a configuration screen with several 

tabs. Each tab is explained in detail in the following sections. 

GoldLink Tooltips 

Note that if you hover the mouse over an option, a brief explanation of the option pops up on a yellow 

background: 
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General tab 

Settings on this tab apply to GoldLink in general. 

 

Global "Master Switch":  Enable link between GoldMine and 3CX 

The master “on-off” switch for GoldLink to 3CX.  

Uncheck this box to turn off all interaction between GoldMine and 3CX. Click Save Settings.  

Check the box to re-enable GoldLink (you will be prompted to restart GoldLink). 

Outbound Dialing:  Trim all but the last 10 digits before dialing outbound number 

If your GoldMine setup is configured to add a prefix to outbound calls (perhaps through PREDIAL.INI), 

this option allows you discard all but the last x digits received from GoldMine. A “digit” is a phone 

keypad digit:  1-9, *, or #. Other characters in the phone number (parentheses, dashes) are not counted. 

This option is enabled by default and set to dial only the last 10 digits received from GoldMine. Outside 

North America, you may want to uncheck this box so longer numbers will be retained. 
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CallerID Handling tab 

Settings on this tab determine how GoldLink handles CallerIDs. 

 

Search Phone1 only 

Search Phone1, Phone2, and Phone3 

You have the option of whether to search for CallerIDs only in the Phone1 field, or in all three phone 

fields. 

Search for CallerID in Additional Contacts if not found in Primary 

You can optionally ask GoldLink to search through all of your additional contacts if it can’t find the 

CallerID in the primary contact. Note that in order for this to work efficiently, you must add an index to 

your database.  See the section “Indexing Additional Contacts.” 

Ignore invocation from 3CX if CallerID is fewer than 6 digits 

3CX invokes GoldLink several times while processing the start, connection, and end of a call. Some of 

these invocations are about calls to 3CX extension or trunk numbers (typically two to five digits). 

Normally you would not want to search for these in GoldMine, so this option allows excluding short 

CallerIDs. Note that GoldLink always excludes non-numeric CallerIDs. 
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Format CallerID before searching 

This “format string” can add parentheses and dashes to a number before searching for it in GoldMine. 

All non-numeric characters are removed before the formatting is applied. If your phone numbers do not 

follow a consistent format, you can uncheck this option to bypass the formatting. Normally this will be 

checked in North America and unchecked elsewhere. 

Ignore leading “1” if CallerID is 11 digits long 

If the CallerID received from 3CX includes a leading “1” (common with North American phone numbers), 

and there are a total of 11 digits, the leading “1” is removed before applying the formatting and 

searching in GoldMine. This allows it to match GoldMine’s USA-Format numbers that omit the leading 

“1”. Normally this will be checked in North America and unchecked elsewhere. 

Remove spaces from CallerID 

If 3CX passes spaces in the CallerID but numbers in GoldMine omit spaces, check this box to remove the 

spaces before searching in GoldMine. UNcheck the box to retain the spaces. Normally this will be 

checked in North America and unchecked elsewhere. 

Show GoldMine contact in current window / a new window 

When GoldLink finds a GoldMine record using the CallerID, it can either show the record in the current 

GoldMine window (which might unexpectedly take you away from a GoldMine record you are working 

on) or in a new GoldMine window.  

Note Due to a GoldMine limitation, if your GoldLink is configured to open the contact in a new window 

and the CallerID is found in an additional contact, GoldLink will only be able to open a new window if the 

primary contact has its first Phone field (Phone1) filled in. If many of your records have no Phone1, 

consider using GoldLink’s current window setting. 

Search on inbound call even if not creating GoldMine history 

Check this to enable searching by CallerID (“popping” the GoldMine record) on each incoming call. This 

is independent of the search that is done when creating GoldMine history, which may happen at the 

start, connection, or end of a call (see the "GoldMine History tab" section). Uncheck this box to disable 

this search on each inbound call. 

while call is ringing or / when you answer the call 

These radio buttons determine whether you want to search for an inbound CallerID while the call is still 

ringing, or only after you answer the call. Most users will want to find the GoldMine record before 

answering the call, so choose while call is ringing. However, users in a ring group, where many phones 

ring on the same call, will probably want to choose when you answer the call so that GoldMine will only 

change records for the user who answers the call. 
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GoldMine History tab 

Settings on this tab determine how GoldLink creates GoldMine history records of incoming and outgoing 

calls. Note that history processing works even if you manually dial your phone. 

 

If contact found, create GoldMine Call History item when call 

Check this box to create GoldMine history records of incoming and outgoing calls. Note that in order to 

create GoldMine history records, GoldLink must first be able to find the contact using the CallerID. 

starts / connects or / ends 

These radio buttons determine whether you want to create the GoldMine history record when the call 

starts (is ringing), is connected (is answered), or ends (is disconnected). Choosing start or ends will 

create a history item even if the call is not completed.  

Fill in Ref with text showing incoming/outgoing and CallerID 

Check this box to automatically fill in the history's Ref field with information about the call, for example, 

"Connected outgoing call to (619)523-0900." If the Ref field already contains text (if you are completing 

a scheduled call), this information is instead inserted at the beginning of the history's Notes. 
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Automatically open history item for editing 

Check this box to have GoldMine to open the history item for editing so you can work on it during the 

call. If this box is unchecked, GoldLink always creates an unscheduled call history item, which you can 

open and edit manually. 

Open before saving in history  

If you select Open before saving in history, GoldMine opens the Complete Call dialog without first 

creating a history item. This has three advantages: 

• You can specify whether to complete a scheduled or unscheduled call. 

• If you don’t want to create a history record for this call, you can simply click on Cancel. 

• If you use the Opportunities / Project drop-down list, only active opportunities or projects are 

listed. 

Some Notes on Workflow There are three sub-options for determining the type of call to complete. 

Choose the one that most closely matches the way you normally work.  

If you schedule calls in GoldMine, most often you will want to complete a scheduled call when you are 

the one making the call (outbound). However if someone calls you (inbound), it may well be about some 

new topic, so you want to treat that as an unscheduled call, leaving scheduled calls in your calendar. If 

this describes your workflow, choose Complete Scheduled Call on outbound calls and Unscheduled Call 

on inbound calls. 

If you prefer, you can instead tell GoldLink to Always complete Scheduled Call or Always complete 

Unscheduled Call. 

Keep in mind that if GoldMine opens a scheduled call and you would rather treat it as an unscheduled 

call or vice versa, you can always click Cancel in the call dialog and complete the call manually in 

GoldMine. 
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Complete Scheduled Call on outbound calls and Unscheduled Call on inbound calls 

This option tells GoldMine to complete a scheduled or unscheduled call depending on whether this is an 

outbound or inbound call. See the next two options for notes on exactly how GoldMine creates 

scheduled and unscheduled calls. 

Always complete Scheduled Call 

This option tells GoldMine to complete a scheduled call. The behavior is the same as when you select 

Complete > Scheduled Call… from the GoldMine menu: 

• If no calls are scheduled for the contact, an empty call dialog appears. 

• If one call is scheduled for the contact, its Ref and Notes fields are copied to the call dialog. 

When you click OK, the history item is created and the pending call is removed from the 

calendar. 

• If multiple calls are scheduled for the contact, GoldMine pops up a window asking you to choose 

which call to complete. That call's Ref and Notes fields are copied to the call dialog. When you 

click OK, the history item is created and the pending call is removed from the calendar. 

In all cases, GoldMine assigns an Activity type of Call Back. You can change this manually to Call In or Call 

Out. 

Always complete Unscheduled Call 

This option tells GoldMine to always complete an unscheduled call, which means an empty call dialog. 

• If GoldLink is processing an inbound call, the behavior is the same as when you select Complete 

> Unscheduled Call > Incoming Call… from the GoldMine menu. GoldMine assigns an Activity 

type of Call In. 

• If GoldLink is processing an outbound call, the behavior is the same as when you select 

Complete > Unscheduled Call > Outgoing Call… from the GoldMine menu. GoldMine assigns an 

Activity type of Call Out. 

Save as Unscheduled Call first, then open for editing 

If you select Save as Unscheduled Call first, then open for editing, GoldMine creates a history record for 

the call, then opens it for editing. This has the advantage of creating a history record for every call. 

However, this option does not allow completing a scheduled call. Also, if you use the Opportunities / 

Project drop-down list, because you are now editing an existing history record, GoldMine lists all of the 

opportunities and projects, whether active or not. 



MCB GoldLink to 3CX User’s Guide 4.0 Rev10  15 

In history item’s Notes, add link to most recent file in this folder 

When checked, GoldLink will search in the specified folder for the newest file and insert a link to that file 

in the history record’s Notes field. If there is already text in the Notes field, the link is inserted before 

the existing text.  

Note File links from GoldMine work in Internet Explorer. Other browsers may have issues. 

This option is most commonly used if you have set up 3CX to record all calls, in which case the folder will 

be a special folder on your 3CX server ending in your extension number. For example, if your 3CX server 

is named 3CXPBX, and if recordings are accessible from the Recordings share, and if your extension is 

101, the path name would be \\3CXPBX\Recordings\101. Note that this must be configured 

separately on each person's computer. If GoldLink tells you that it cannot find the folder, first try typing 

the path name into Windows Explorer. 

Caution Call recording is usually only legal under certain conditions, if at all. Consult your attorney.  

Delay adding link for x seconds (give 3CX time to create) 

Depending on the performance of your 3CX server, your local computer, and your network, you may 

find that GoldLink is searching for the recording file before 3CX has finished creating it. This gives you 

the option of waiting a few seconds before GoldLink looks for the file. Note that this will delay creating 

the history record and opening the record for editing. By default, this option is checked and set to 3 

seconds. 

Only add link if the file was created in the last x seconds 

This serves as a “double-check” to make sure that GoldLink is finding the current recording file. If you 

were to disable recording on the 3CX server, the newest recording file might be a week or a month old. 

With this option set, this old file will not be linked to each new call. By default, this option is checked 

and set to 20 seconds. 

Important For this work correctly, the clock on each workstation must be synced with the clock on the 

3CX server. 

Only add link if the name includes the 3CX Call Identifier no. 

Every call in 3CX has a Call Identifier number. If you are linking to 3CX recordings, the Call Identifier 

appears in parentheses at the end of the file name. For example, consider file name: 

[MCB Systems]_110-6195551212_20170313215558(9).wav 

This recording is for Call Identifier 9, made by extension 110 on March 13, 2017 at 9:55:58pm GMT 

(215558). 

If this box is checked, GoldLink will only link the file if the file name includes the current CallID. Note that 

after an attended transfer, the CallID provided by 3CXPhone to GoldLink may not match the CallID in the 

recording file name. Since CallID is not always reliable for verifying the recording file name, this option is 

unchecked by default. 
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Advanced tab 

Settings on this tab specify advanced GoldLink options. 

  

Always show form 

Normally, the GoldLink form (that is, its user interface) will not appear when processing calls. Checking 

this box causes the form to appear every time you call out from GoldMine, or whenever 3CX sends a 

start, connect, or end call event. Only check this box for troubleshooting purposes. 

Auto-process call if form shown 

Normally, if GoldLink is called by GoldMine or 3CX, it immediately processes the call (searching by 

CallerID and creating GoldMine history). If you uncheck this box, the form will appear but the call will 

not be processed automatically. This can be useful to see what instructions are being received by 

GoldLink without actually acting on them. You can click on the Process Call button to process the call. 

Write Status messages to a log file (view from Paths tab) 

When checked, the messages that appear on the Status tab are also written to a file. This option should 

only be enabled for troubleshooting, as the log can grow quite large. The log file is saved in the 

Application Data folder that is shared by all users on your computer:  

C:\ProgramData\MCB Systems\GoldLinkTo3CX\GoldLinkTo3CX.log 

To open the file, in GoldLink, click on the Params button, then on the Paths tab, look for Path to this 

program’s log file. You can delete this log file whenever you want; it is not required by GoldLink.  

However be careful not to delete the .lic (license) file saved in the same folder! 

Log GoldMine interactions longer than x seconds 

GoldLink uses the Microsoft Component Object Model (COM) to communicate with GoldMine. COM 

interactions should normally take a fraction of a second. If a COM “call” takes over one second (by 

default), it is logged in the log file. These log entries can help support troubleshoot communication 

problems.  
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Status tab 

This tab shows details about the interaction between GoldMine, GoldLink, and 3CX. Normally you will 

only need to review this information for troubleshooting purposes. You will only see the Status box 

during automated call processing if Always show form is checked. 

 

About tab 

This tab shows program version and copyright information. 
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Program Buttons 

There are several buttons down the right side of the window. 

Save Settings 

Click this button to save your configuration settings so they will be used when GoldLink is invoked by 

GoldMine or 3CX. 

Restore Defaults 

Click this button to restore the program’s default settings. 

Process Call 

If parameters have been supplied to the program, press this button to act on them. 

Exit 

Press this button to exit the program. If you have unsaved configuration changes, you will be asked 

whether you want to save them. 

Request Lic. 

See “Requesting and Activating a GoldLink License” below. 

Activate Lic. 

See “Requesting and Activating a GoldLink License” below. 

Params 

Click this button to open or close the “Parameters” part of the program window. The values on the 

Parameters tabs are filled in automatically when GoldLink is invoked from GoldMine (for outbound calls) 

or from 3CX (for inbound and outbound calls). For testing and troubleshooting, you can fill in values 

manually and process the call by pressing the Process Call button. 
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Configuring GoldLink for Use Outside North America 
Some of GoldLink's defaults assume that you are working with fixed 10-digit phone numbers formatted 

in GoldMine as (nnn)nnn-nnnn. When that is not the case, you can configure GoldLink to work with 

longer, unformatted numbers.  

GoldMine Configuration 

In GoldMine, the record must be configured to format its numbers in a "Non-USA Format". When adding 

a record, you can specify this by checking International Phone Format: 

 

You can view or change the setting for the current record from Edit > Record Properties > Record-

related Settings: 

 

GoldLink Configuration 

To allow GoldLink to process long, unformatted numbers, make the following adjustments to your 

GoldLink settings: 

On the General tab, uncheck Trim all but the last n digits before dialing outbound number: 
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On the CallerID Handling tab, uncheck the following settings: 

• Format CallerID before searching 

• Ignore leading "1" if CallerID is 11 digits long 

• Remove spaces from CallerID 

 

Click Save Settings to save these changes so they apply to future calls. 

3CX Configuration 

GoldMine and GoldLink are now configured to pass unformatted numbers back and forth between 

GoldMine and 3CX. This has two implications: 

• When you dial from GoldMine, 3CX must be able to handle the number as formatted in 

GoldMine. 

• When you receive an incoming call, in order for GoldLink to find the contact in GoldMine, the 

CallerID passed in from 3CX must exactly match the format in GoldMine. 

Depending on your region and how your VoIP provider formats CallerIDs, you may need to use 3CX's 

Caller ID reformatting rules as explained here:  https://www.3cx.com/docs/cid-reformatting/.  

Keep in mind that international numbers may be formatted differently than domestic numbers. Be sure 

to test inbound and outbound domestic and international numbers as you decide how to store your 

numbers in GoldMine and as you configure your CallerID formatting rules. 

Here is a helpful guide for U.K. numbers:   

https://www.area-codes.org.uk/formatting.php 

And a similar guide for Australia: 

https://www.australia.gov.au/about-australia/facts-and-figures/telephone-country-and-area-codes 

https://www.3cx.com/docs/cid-reformatting/
https://www.area-codes.org.uk/formatting.php
https://www.australia.gov.au/about-australia/facts-and-figures/telephone-country-and-area-codes
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Indexing Additional Contacts 
In order for the GoldLink feature Search for CallerID in Additional Contacts if not found in Primary to be 

able to find Additional Contacts quickly, you will need to add indexes on the Additional Contacts’ Phone 

and Fax fields (“Fax” is the legacy internal name now used for “Mobile”). This is only supported for 

Microsoft SQL databases. 

Note Adding indexes is a database administration task and requires familiarity with Microsoft SQL 

administration tools. Provide these instructions to your database administrator. 

Follow these instructions to add index on ContSupp’s Phone and Fax fields to your database: 

1. Ask users to log off GoldMine. 

2. Back up your GoldMine database. 

3. In SQL Management Studio, open the GoldMine database and navigate to the CONTSUPP table. 

Right-click on Indexes and select New Index > Non-Clustered Index…. 
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4. In the New Index dialog, give the index a unique name, for example ContSupPhone. Click on the 

Add… button and check the PHONE field. Click on OK, then OK again to create the index. 

 
5. Repeat steps 3 and 4 to add the ContSupFax index on the FAX field. 

If you prefer to work in Transact SQL, the following command will add the index: 

CREATE NONCLUSTERED INDEX [ContSuppPhone] ON [dbo].[CONTSUPP] 

 ( [PHONE] ASC )  

ON [PRIMARY] 

CREATE NONCLUSTERED INDEX [ContSuppFax] ON [dbo].[CONTSUPP] 

 ( [FAX] ASC )  

ON [PRIMARY] 

Note Although indexing does not require exclusive access to SQL and does not change user data, it is 

always a good idea to create a SQL backup before modifying the database structure. Performance may 

slow down while the index is being built, which is why we recommend that users be logged out of 

GoldMine. How long that will take depends on your environment, but normally SQL should be able to 

index 10,000 records in a matter of seconds. 
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6. Using GoldLink 
Once you have configured GoldLink and saved your settings, you will normally never see the GoldLink 

user interface.  

Outbound Dialing 
To dial out from GoldMine via GoldLink and 3CX, find the contact you want to call in GoldMine, right-

click on the appropriate phone number, and select Dial Phone: 

 

You can also press Alt+1 to dial Phone1, Alt+2 for Phone 2, or Alt+3 for Phone3. 

To dial an Additional Contact, right-click on the contact and select Options > Dial: 

 

Note If the GoldMine record’s properties specify that the contact uses USA Format numbers, the 

number must be at least 7 digits long to dial out through GoldLink. Non-USA Format numbers can be any 

length. 

Note When the 3CXPhone software is in CTI mode (integrated with a desktop phone), the desktop 

phone will immediately ring with a caller ID of ”Make Call”. When you answer the desktop phone, you 

will hear hold music while 3CX dials the number. When the other party answers, you will be connected. 
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Searching by CallerID on Incoming Calls 
If you checked Search for CallerID in GoldMine at the start of each incoming call and the CallerID is 

found, GoldLink will position GoldMine to the matching record, either in the current window or in a new 

window. Here GoldMine searched for (619)523-0900 and when found, opened the contact in new 

window (tab): 

 

You will also see a status message in the lower left corner of the GoldMine window: 

 

If the CallerID cannot be found, you’ll see a message like this: 
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History Creation and Editing 
Depending on how you have configured GoldLink, you may see a GoldMine Call History dialog appear, 

optionally with a link to a file. You can type additional notes and change other fields. Click on OK to save 

your changes: 

 

Once the history is saved, it will appear in the list of history records for that contact, optionally with a 

clickable link to a file in the Preview pane: 

 

Note The file link is stored in the GoldMine history record’s Notes field in HTML format. If you want to 

be able to edit history Notes using HTML formatting, in GoldMine, go to Tools > Configure > System 

Settings and choose the Display tab. Under Notes Format, select HTML, then click on OK. 

Note File links from GoldMine work in Internet Explorer. Other browsers may have issues. 
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7. Requesting and Activating a GoldLink License 
GoldLink runs in trial mode with full functionality for 30 days. After that, you must purchase a license to 

continue using GoldLink. 

1. To request a license, click on the Request Lic. button. A message appears explaining the process: 

 
 

2. Type in the name under which you want to register your license, and click on OK: 

 
 

3. If you have an email program on your computer, a new email window will open containing a 

long string. Send this email to licenses@mcbsys.com:  

 
If you do not have an email program on your computer, a message appears telling you where to 

mailto:licenses@mcbsys.com
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find the license request file. Attach that file to an email and send it to licenses@mcbsys.com: 

 
 

4. Once payment is confirmed, MCB Systems will send back a long string of letters and numbers to 

use for activating your license. Click on the Activate Lic. button, paste the string into the box, 

and click on OK. 

 
 

5. A message will appear telling you that the license has been activated. Close and re-open 

GoldLink.  

Once your license is activated, you will see “Licensed to” and your name below the Exit button: 

 

mailto:licenses@mcbsys.com
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8. Troubleshooting 

Access Denied Error During Installation 
If you get an “Access is denied (5)” error when installing GoldLink, it could be that your anti-virus 

program is incorrectly identifying one of the GoldLink components as a virus. 

 

Check your anti-virus log and/or quarantine to determine if the anti-virus is the issue.  

If the anti-virus is blocking the GoldLink installer, first, confirm that your installer is clean. One helpful 

resource is www.virustotal.com. You can upload the installer there to check it against over 60 anti-virus 

engines. 

Once you know that you have a clean installer, use one of these methods to install GoldLink without 

interference from the anti-virus program: 

• Temporarily disable the anti-virus program. 

• Exclude the GoldLink installer from the anti-virus detection. (This may be difficult since the 

installer creates sub-tasks in a temporary folder.) 

• Reboot the computer into Safe Mode, then install GoldLink. 

If you do confirm that your anti-virus software was blocking the GoldLink installation, please let MCB 

Systems know so we can ask the anti-virus vendor to remove the false positive. 

http://www.virustotal.com/
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Dial Menu Not Available in GoldMine 
A GoldMine administrator can “lock down” access to menus for non-master users. The Dial Phone 

menus must be enabled to allow outbound dialing from GoldMine. 

1. Log on to GoldMine as a master user. 

 

2. Select Tools > Users’ Settings. Highlight the user that should be able to dial and click on the 

Properties button. 

 

3. Click on the Menu tab. Under Actions > Call Contact, make sure that the Dial Phone options are 

green: 

 
Note  The preferred way to set up menu access is by using saved menu layouts. This allows you 

to quickly apply an entire menu structure to a user. For example, you could set up a “Phone 

User” layout that includes all Dial Phone menu items. See the drop-down list and the Save and 

Delete buttons above. 

 

4. Log back in as the user needing Dial Phone access. The user should now be able to choose 

Actions > Call Contact > Dial … from the menu. Also, after right-clicking on a phone number, the 

context menu should include the Dial Phone command:  
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The Windows Modem Dialog Opens When Dialing 
You may see the Windows Location Information dialog when you first dial out: 

 

This means that Windows has detected a modem connected to your computer. It wants set up the 

default location for the modem. It is suggested that you set the area code to 999 (see the 

troubleshooting tip, “GoldMine Omits the Local Area Code When Dialing”). Leave the second and third 

fields blank. 

Note A cell phone attached via USB cable to your computer may also be recognized as a modem! 

If you disconnect the modem (or cell phone) and find that GoldMine keeps popping up the Telephony 

dialog, in the GoldMine folder, check your user.INI file for the [Modem] section. If you see this: 

[Modem] 

DeviceID=-1 
 
Try changing it to the dummy modem setting: 
 
[Modem] 

DeviceID=0 
 
Close and restart GoldMine, then test dialing out. 
 
Alternatively, you can delete everything in the [Modem] section, then with GoldMine running, start 
GoldLink. You will be asked whether GoldLink can create a dummy modem for you. 
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GoldMine Opens Telephony Options Instead of Dialing 
If GoldMine opens the Telephony options dialog when you try to dial out, it may be wanting you to 

configure the GoldMine softphone. GoldLink to 3CX does not use GoldMine softphone, so the softphone 

should be disabled. From Tools > Options, go to the Telephony tab, uncheck Start SoftPhone with 

GoldMine, uncheck Use SoftPhone by default, then restart GoldMine to make sure the settings take 

effect: 

  

Note In at least one GoldMine 2019.1 installation, Use SoftPhone by default appears checked even if 

you uncheck it and restart GoldMine. However, the value stored in the user’s INI file correctly shows 

that UseByDefault is disabled: 

[SoftPhone] 

AutoStart=0 

UseByDefault=0 

 
The unexpected checkmark in the Telephony tab does not seem to impact GoldLink functionality. 

However if you change other values in the Options dialog, you should uncheck Use Softphone by default 

again. 
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GoldMine reports “You do not have Security Access to this option…” 
If you try dialing out and get the GoldMine message, “You do not have Security Access to this option,” 

the dummy modem may not be configured in your INI file.  With GoldMine running, start GoldLink 

manually. If you a message asking if it is okay to define a dummy modem, click Yes and restart 

GoldMine. 
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GoldLink Could Not Find GoldMine <User>.INI File 
You may see this message when 3CX tries to start GoldLink, e.g when you receive an inbound call: 

 

If you start GoldLink manually, click on the Params >> button, click on the Paths tab, and check the Path 

to GoldMine <user>.INI file, you see that the path is valid. If you click the Open button, the file opens. 

So you know the file is there and is accessible from this PC. 

This can happen if you start 3CXPhone for Windows as an administrator. 3CXPhone launches the 3CX 

Command Line API Plugin, which launches GoldLink. So GoldLink also runs as administrator. But the 

administrator context does not have a mapped drive pointing to your GoldMine installation, so when 

GoldLink looks for <user>.INI file, it can’t find the network drive. 

While it may be possible to map network drives for the administrative context, the simplest solution is 

to run 3CXPhone as a normal user. 
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GoldLink Could Not Retrieve the GoldMine Path 
GoldLink runs with non-elevated permissions by default. If GoldMine is run with eleveated permissions 

(as Administrator), GoldLink will not be able to retrieve GoldMine's path and may report that GoldMine 

is not running even though it is. As of GoldLink version 4.2.0.3, you'll see this message in this situation: 

 

Close GoldMine and re-open without elevated permissions. (Do not run as Administrator). 
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GoldLink Could Not Connect to GoldMine's User Interface 
The GoldMine program (gmw.exe) must be installed on your computer's local drive, not run across the 

network (although the actual data is stored on a network database server). Also, GoldMine must register 

itself as a "COM server" to be able to respond to instructions from GoldLink.  

If GoldMine is not installed locally, or if the COM registration is missing or corrupt, you'll see this 

message when 3CX starts: 

 

If GoldMine is already installed locally, try registering its COM server by typing the following from a 

command prompt (opened with "Run as sdministrator"): 

"C:\Program Files (x86)\GoldMine\gmw.exe" /RegServer 
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GoldLink Is Not Processing Any Calls 
Check for these possible issues. 

Is the 3CX Command Line API Plugin installed? 

GoldLink communicates with 3CX through the 3CX Command Line API Plugin, which is automatically 

installed when you install GoldLink. You should see it near the top of your list of installed programs: 

 

Did the Plugin Load Successfully? 

The plugin loads automatically when start 3CXPhone for Windows. Try exiting and restarting 3CXPhone. 

Then check the plugin’s log file to make sure the plugin loaded correctly. By default, the log is in this 

path: 

%AppData%\3CXCommandLineAPIPlugin\Logs\3CXCommandLineAPIPlugin.log 

Look for these messages from the last time you started 3CXPhone for Windows: 

ImportantEvents: C:\ProgramData\3CXPhone for 

Windows\PhoneApp\CommandLineAPIPlugin.dll version x.x.x.x initialized. 

ImportantEvents: GoldLinkTo3CX 4 - License validated 

Are You Using the Pro Edition of 3CX? 

Plugins only work with the Pro edition of 3CX. The PBX and Standard editions will not work. In 3CX 14 

Server Manager, go to Settings > Activate License to make sure you have 3CX 14 Pro Edition: 
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If you are running 3CX 15, from the dashboard, in the Information box, click on License. In the License 

Settings screen, confirm that you have 3CX 15 Pro edition: 
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GoldMine Omits the Local Area Code When Dialing 
If your 3CX setup requires that you include the area code when dialing local numbers, in the GoldMine 

Telephony Options dialog, tell GoldMine that your Local Area Code is 999: 

 

If you have a physical modem installed, you may need to make this setting in the Windows Control 

Panel.  Under Phone and Modem > Set up dialing rules, change the area code to 999: 
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GoldLink Is Not Processing Outbound Calls – "Call Transfer Failed" 
If GoldLink is handling inbound calls but cannot dial outbound (e.g. generating "Call Transfer Failed" 

messages), there may be an issue with the format of the number received from GoldMine or passed to 

3CX. In GoldLink, check Always show form, click Save Settings, then review the messages in the Status 

box when dialing.  

• If GoldMine is passing too many digits to GoldLink, you can trim leading digits by using the 

GoldLink option Trim all but the last x digits before dialing outbound number. In North 

America, assuming your 3CX installation handles 10-digit dialing to any number (local or long 

distance), you would normally set this to trim all but the last 10 digits. 

• If the parameter passed from GoldMine begins with &Dial,,C:\GoldLinkTo, you are 

probably trying to dial a USA Format number with fewer than 7 digits. Change the GoldMine 

contact record to Non-USA Format, or enter a phone number of at least 7 digits (GoldMine will 

add your local area code to make it 10 digits). 

When GoldLink is working as expected, uncheck Always show form and click Save Settings. 
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GoldLink Is Not Processing Outbound Calls – Just Goes Off Hook and Stalls 

Symptoms 

• You try to dial out from GoldMine but the call is not dialed—the desk phone never rings to start 

the Make Call. 

• If you receive an incoming call, or if you manually dial a call from the desk phone, GoldLink 

opens the history dialog as expected, so GoldLink is working. 

• 3CX Phone shows that it is off hook (red bar) but does not show the number. You can end the 

call in 3CX Phone but it doesn’t fix the problem. 

• The GoldLinkTo3CX.log file shows “Dialed nnnnnnnnnn using 3CX.” 

• Even when set to log AllEvents, the 3CXCommandLineAPIPlugin.log file does not show the call 

being dialed. 

• Re-starting 3CX Phone did not help. Logging off and on did not help. 

Cause 

Log on to the 3CX 14 dashboard. Under Troubleshooting > Activity Log, check whether 3CX shows that a 

call is active although none is. Under System Status > Extensions View, look for the connected call, for 

example to the voicemail extension 99: 

 

In this case, perhaps half an hour earlier, the Internet went offline briefly while the user was listening to 

a voicemail on the desk phone, and the call dropped. However, obviously it wasn’t a clean drop—the 

phone wasn’t able to send the SIP “BYE” messages ending the call—so 3CX thought the call was still in 

progress. In this state, the desk phone (with only one line dedicated to 3CX) was not able to receive the 

Make Call connection for outbound dialing. 

Solution 

In the dashboard under System Status > Extensions View, highlight the Connected call and click 

Disconnect Call. After that, dialing out should work again. 

Note In 3CX 15: 

• Activity Log is a large blue button on the dashboard 

• To see active calls, on the dashboard, in the PBX Status box, click on Number of calls in use. 
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Can’t Open Link to File 
Note In testing, GoldMine version 8.5 was unable to open links to .wav files found in the Notes field of 

GoldMine history records. GoldMine 6.5 and 9.0 can open the links. 

Note File links from GoldMine work in Internet Explorer. Other browsers may have issues. 

Opening a link to a file from a GoldMine history record is similar to opening a link on a web page. Your 

computer must be configured to handle the file type (in the case of 3CX recordings, these are .wav files).  

Also, your computer must trust that the file is coming from a safe source. While several factors can 

affect this, by default, Internet Explorer is configured as shown below to allow access to files on the local 

network (“intranet”): 
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GoldLink is Not Inserting Link to Recording in GoldMine History Notes 
Double-check the settings described under “In history item’s Notes, add link to most recent file in this 

folder” on page 15. 

If all other features are working but the link is not getting inserted (even if it used to work), the time on 

your workstation may be different from the time on the 3CX server, which can cause the rule “Only add 

link if the file was created in the last x seconds” to fail. This is because file time stamps are created by 

the server but the age of the file is checked by the local PC. It is suggested that all computers in the 

environment be synchronized to a good time source using the Network Time Protocol (NTP). 

GoldLink Is Not Positioning to a GoldMine Record on an Inbound Call 
This will happen in the following scenario: 

• You check Search for CallerID in Additional Contacts and Show GoldMine contact in a new 

window. 

• The CallerID is found in an Additional Contact 

• The corresponding primary contact does not have a main Phone number (Phone1). 

Cause 

The only practical way to open and position in a new GoldMine window is to use the GoldMine API’s 

[CallerID(Phone1)] function, so the main phone number must be filled in. Positioning in the current 

window does not have this limitation. 

Workaround 

Either fill in the primary contact’s main phone number, or configure GoldLink to Show GoldMine contact 

in the current window. 

GoldLink Is Positioning to the Wrong GoldMine Record on an Inbound Call 

Cause 

GoldLink always positions to the first record that matches the CallerID. If multiple primary records have 

the same phone number, GoldLink will position to one of those records. 

Workaround 

Assign unique phone numbers to contacts, or manually move to the correct record after GoldLink 

positions to a different record than expected. 
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9. Technical Reference 
Several technologies must work together for GoldMine to communicate with GoldLink and GoldLink 

with 3CX. 

For communication with GoldMine, GoldLink uses both Dynamic Data Exchange (DDE) and the 

Component Object Model (COM) API. These technologies are documented in Integrating with GoldMine:  

API Specifications and Examples, available to GoldMine customers and integrators. 

For communication with 3CX, GoldLink was programmed based on the 3CX CRM Command Line API as 

defined here: 

https://web.archive.org/web/20140715160436/http://www.3cx.com/blog/docs/command-line-api/ 

That API was removed after 3CX 11, so starting with 3CX 14, MCB Systems wrote an API “bridge” called 

the 3CX Command Line API Plugin that takes events from 3CXPhone for Windows and converts them 

back to the Command Line API format. This allows GoldLink to continue to work with the new 3CX 

plugin-based architecture. 

The following sections identify several log files and registry entries that are required for GoldLink to 

communicate with 3CX. Some of these settings are visible in the GoldLink interface when you click on 

the Params >> button, then the Paths or Registry tabs. 

Log Files 
These are the default log file locations. 

MCB GoldLink to 3CX 
C:\ProgramData\MCB Systems\GoldLinkTo3CX\GoldLinkTo3CX.log 

3CX Command Line API Plugin 
%AppData%\3CXCommandLineAPIPlugin\Logs\3CXCommandLineAPIPlugin.log 

Install and Uninstall Logs 
%temp%\Setup Log yyyy-mm-dd #nnn.txt 

%temp%\Uninstall Log yyyy-mm-dd #nnn.txt 

https://web.archive.org/web/20140715160436/http:/www.3cx.com/blog/docs/command-line-api/
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Registry Settings for GoldLink to 3CX 
On 64-bit versions of Windows, registry settings are under Wow6432Node. 

 Key: HKLM\Software\[Wow6432Node\]3CX\CRM\CallNotifierPath 

 Default value: C:\GoldLinkTo3CX\GoldLinkTo3CX.exe 

 Purpose: Identifies the program that the 3CX Command Line API Plugin runs to notify of 

inbound and outbound call events. (The plugin receives notifications from 3CXPhone 

for Windows and “translates” them to the Command Line API format.) 

 

 Key: HKLM\Software\[Wow6432Node\]3CX\3CXPhone for Windows\Path 

 Default value: C:\ProgramData\3CXPhone for Windows\PhoneApp\ 

 Purpose: Path to the local installation of 3CXPhone for Windows. The following files must be in 

this path: 

CallTriggerCmd.exe:  The program that GoldLink runs to dial out via 3CX. This 

program is included with 3CXPhone for Windows. 

CommandLineAPIPlugin.dll:  The 3CX Command Line API Plugin. 

3CXWin8Phone.user.config:  The config file that lists CRM plugins to load. 

Registry Settings for the 3CX Command Line API Plugin 
These settings are optional. Default value will be used if they are not defined. Note that they are defined 

per user, in the HKEY_CURRENT_USER (HKCU) hive. The HKCU hive does not use the Wow6432Node. 

 Key: HKCU\Software\3CX\CRM CommandLineAPILogPath 

 Default value: %AppData%\3CXCommandLineAPIPlugin\Logs 

 Purpose: Folder where the plugin will store its log file. Do not include the file name. If this key is 

blank or not defined, the default path is determined dynamically when the plugin 

loads. Because %AppData% is user-specific, each user will have their own log. 

 

 Key: HKCU\Software\3CX\CRM CommandLineAPILogLevel 

 Value options: ImportantEvents 
AllEvents 

 Default value: ImportantEvents 

 Purpose: Whether to log important events (version and license information when the program 

starts) or all events (every time the plugin runs GoldLink). If this key is blank or 

undefined, only important event are logged. You can temporarily set this to 

AllEvents for debugging purposes, but this will cause the log file to grow quickly, so 

it should be set back to ImportantEvents for routine call handling. 
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